1.Напишите программу для решения задачи с использованием линейного массива: Ученики 4...

0 голосов
88 просмотров

1.Напишите программу для решения задачи с использованием линейного массива: Ученики 4 класса вели дневники наблюдения за погодой и ежедневно записывали дневную температуру. Найдите среднюю температуру для дней, когда температура поднималась выше нуля градусов. Определите количество таких дней. Гарантируется, что за время наблюдения хотя бы в один из дней температура поднималась выше нуля градусов. Программа получает на вход количество дней, в течение которых проводилось наблюдение N (1 ≤ N ≤ 31), затем для каждого дня вводится температура.


Информатика (36 баллов) | 88 просмотров
Дано ответов: 2
0 голосов

Ответ:

Var n,S,k,t:integer;

Begin

S:=0;

k:=0;

Read(n);

For n:= 1 to n do

   Begin

   Read(t);

   if t > 0 then

      Begin

      S:=S+t;

      k:=k+1;

      End;

   End;

WriteLn('k = ',k);

Write('Sr = ',S/k)

End.

Подробнее - на Znanija.com - znanija.com/task/24688454#readmore

Объяснение:

(54 баллов)
0 голосов

#Python

array = []

plus_days = 0

for x in range(int(input())):

   day = int(input())

   if day > 0:

       array.append(day)

       plus_days += 1

print(plus_days)

print(sum(array) / len(array))

(439 баллов)