Напишите программу для решения задачи с использованием линейного массива: Ученики 4...

0 голосов
82 просмотров

Напишите программу для решения задачи с использованием линейного массива: Ученики 4 класса вели дневники наблюдения за погодой и ежедневно записывали дневную температуру. Найдите самую низкую температуру за время наблюдения. Если температура опускалась ниже –15 градусов, выведите YES, иначе выведите NO. Программа получает на вход количество дней, в течение которых проводилось измерение температуры N (1 ≤ N ≤ 31), затем для каждого дня вводится температура.


Информатика (36 баллов) | 82 просмотров
Дано ответов: 2
0 голосов

#Python

deys = []

for x in range(int(input())):

   deys.append(int(input()))

if min(deys) < -15:

   print('YES')

else:

   print('NO')

(439 баллов)
0 голосов

Ответ:

var N,i,k,z:integer;   

     s:real;

begin

s:=0;

k:=0; 

repeat 

   write('Введите кол-во дней : ');  

   readln(N); 

until (N>=1) and (N<=31); {проверка на верное количество дней}</p>

for i:=1 to N do 

begin 

   write ('Введите значение температуры в ',i,' день : '); 

   readln(z); 

   s:=s+z; 

   if z>0 then k:=k+1; 

end;

s:=s/N;

writeln('Средняя температура = ',s);

if k>=5 then writeln('YES') else writeln('NO');

end.

Подробнее - на Znanija.com - znanija.com/task/10735596#readmore

Объяснение:

(54 баллов)