1. Напишите программу, которая генерирует 10 случайных чисел от 1 до 20,выводит числа **...

0 голосов
115 просмотров
1. Напишите программу, которая генерирует 10 случайных чисел от 1 до 20,выводит числа на экран и вычисляет их сред арифм.
2.
напишите прог, в которой осуществляется ввод целых чисел,до тех пор, пока не будет введен 0 и определено максимальное из введенных чисел


Информатика (26 баллов) | 115 просмотров
0

Язык какой?

0

паскаль

Дан 1 ответ
0 голосов
Правильный ответ
Задача 1
Var i,sum:integer;
      mas:array [1..10] of integer;
Begin 
  for i:=1 to 10 do begin         
     mas[i]:=random(20);           
      write(' ',mas[i]);           
     sum:=sum+mas[i];                   
                         end; 
writeln; 
   write('Среднее арифметическое этих чисел = ',sum/10);
End.

Задача 2 
Var i,max:integer;
Begin 
readln(i); 
    while (i<>0) do begin   
       if (i>max) then max:=i;   
          readln(i);     
                       end; 
  Writeln('Максимальное число: ',max);
End.
(8.6k баллов)