1.Написать программу, которая вычисляет частное двух чисел. Программа должна проверять...

0 голосов
174 просмотров

1.Написать программу, которая вычисляет частное двух чисел. Программа должна проверять правильность введенных пользователем данных и, если они неверные (делитель равен нулю), вы давать сообщение об ошибке. Ниже приведен рекомендуемый вид экрана во время выполнения программы (данные, введенные пользователем, выделены полужирным шрифтом).
Вычисление частного.
Введите в одной строке делимое и делитель,
затем нажмите .
-> 12 О
Вы ошиблись. Делитель не должен быть равен нулю.


Информатика (27 баллов) | 174 просмотров
0

на каком языке программирования тебе нужно?

0

Pascal

Дан 1 ответ
0 голосов

Program qq;
Var a, b, c:real;
Begin
Writeln('введите два числа');
Readln(a,b);
If b=0 then begin writeln('делитель не должен равняться нулю, введите числа повторно')
readln(a, b);
End
If else begin c:=a/b;
End
Writeln('получившееся число', c)
End.
Может где-нибудь есть косячок, но в основном, все должно получиться, удачи:)

(100 баллов)