Помогите, срочно!! 1. Написать программу суммирующую числа до тех пор пока не будет...

0 голосов
58 просмотров

Помогите, срочно!! 1. Написать программу суммирующую числа до тех пор пока не будет введён "0". Входные данные: 1 2 3 0 Выходные данные: 6 2. Написать программу поиска НОД (Наибольший Общий Делитель) двух чисел. Входные данные: 170 42 Выходные данные: 2


Информатика (14 баллов) | 58 просмотров
0

На языке Pascal

0

Буду очень благодарен!!

0

Спасёте от 2 в четверти

0

хотя бы первую решите, пожалуйста

0

Не совсем понятно, это только 4 числа вводится, или бесконечность?

0

4 числа

0

Тогда код ниже

0

Ошибка компиляции

0

Попробуй ещё раз

0

Всё, спасибо!!

Дан 1 ответ
0 голосов

1)

program g;

var

a, b, c, d:integer;

begin

Readln(a, b, c, d) ;

begin

if a = 0 then

Writeln('0') end ;

begin

if b = 0 then

Writeln(a) end ;

begin

if c = 0 then

Writeln(a + b) end ;

begin

if d = 0 then

Writeln(a + b + c) end ;

end.

(534 баллов)
0

Ошибка компиляции(

0

Попробуй ещё раз

0

Пасиба!