Напишите программу, которая находит частное (суммы всех четных чисел) / (Разность всех...

0 голосов
41 просмотров

Напишите программу, которая находит частное (суммы всех четных чисел) / (Разность всех нечетных чисел), записанных в файле в столбик, и выводит результат в другой файл.


Информатика (72 баллов) | 41 просмотров
Дано ответов: 2
0 голосов

#include

using namespace std;

signed main() {

   freopen("input.txt","r",stdin);

   freopen("output.txt","w",stdout);

   int x;

   double sum = 0,dif = 0;

   while(cin >> x){

       if(x % 2 == 0)

           sum += x;

       else

           dif -= x;

   }

   cout << sum/dif;</strong>

   fclose (stdout);

}

(670 баллов)
0

паскаль

0

Язык нужный в вопросе указывают, а не после получения ответа.

0

не знал сори

0

у меня 2 подобные задачи за 50 баллов уже стоят не решенные, если можете помогите

0 голосов

// PascalABC.NET

begin

 var (se, so) := (0, 0);

 foreach var s in ReadLines('input.txt') do

 begin

   var t := s.ToInteger;

   if t.IsEven then

     se += t

   else

     so += t

 end;

 WriteAllText('output.txt', (se / so).ToString)

end.

(1.6k баллов)