PYTHON Делители числа Напишите программу, которая отображает все делители числа N....

0 голосов
444 просмотров

PYTHON Делители числа Напишите программу, которая отображает все делители числа N. Входные данные: вводится единственное натуральное число n. Выходные данные: на одной строке вывести все делители данного числа. Используйте для вывода параметр end = " " с командой print(). Пример: print(x, end = " "). Пример 1 Ввод: 12 Вывод: 1 2 3 4 6 12В пайтоне, пожалуйста...​


Информатика (12 баллов) | 444 просмотров
Дан 1 ответ
0 голосов

a = int(input("Введи число: "))

for i in range(1,a+1):

   if a%i == 0:

       print(i,end = " ")


image
image
(4.0k баллов)