Программа ** c++ Дан массив, состоящий из целых чисел. Напишите программу, которая...

0 голосов
320 просмотров

Программа на c++ Дан массив, состоящий из целых чисел. Напишите программу, которая определяет, есть ли в массиве пара соседних элементов с одинаковыми знаками. Входные данные Сначала задано число N — количество элементов в массиве (1N10000). Далее через пробел записаны N чисел — элементы массива. Массив состоит из целых чисел. Выходные данные Необходимо вывести слово YES, если существует пара соседних элементов с одинаковыми знаками. В противном случае следует вывести слово NO. Примеры входные данные 5 1 -3 4 -2 1 выходные данные NO


Информатика (146 баллов) | 320 просмотров
Дан 1 ответ
0 голосов

Ответ:

int n, p,q;

cin >> n;

cin >> p;

bool stop = false;

for(int i = 2; i < n && !stop; i++) {

cin >> q;

if(p == q) fl = true;

p = q;

}

if(!stop) cout << "NO"; else cout << "YES";</p>

Объяснение:

(88 баллов)