Напишите программу для вычисления значения выражения y=5x+20 где x целое число, вводимое...

0 голосов
1.4k просмотров

Напишите программу для вычисления значения выражения y=5x+20 где x целое число, вводимое с клавиатуры. Решить, как программу Паскаль.


Информатика (14 баллов) | 1.4k просмотров
0

begin Print(5*ReadInteger+20) end. На PascalABC.NET

Дан 1 ответ
0 голосов

Відповідь:

program myprog01;

var

 y: Integer;

 x: integer;

begin

  Write('Input x=? ');

  Readln(x);

  y := 5*x + 20;

  Writeln('y = 5x+20 = ', y);

end.

Пояснення:

(4.3k баллов)
0

10 строк вместо одной. Маладэц!

0

уверен

0

1) уверен. 2) PascalABC.NET немножко не Pascal. в классическом паскале - так. 3) одна строчка - не означает одна команда.

0

А в вопросе написано, что нужно решение в "классическом паскале"?

0

А еще, то что Вы называете "классическим Паскалем", давно умерло и осталось только в умах учителей, которые сами изучали его 30 лет тому назад и с тех пор ничему новому не научились.

0

Особенно вот этот program myprog01; - анахронизм образца 1974 года.