Каждую задачу оформить в виде программы и блок-схемы в тетради. 1)Определить, делится...

0 голосов
141 просмотров

Каждую задачу оформить в виде программы и блок-схемы в тетради. 1)Определить, делится ли целое число Х на 5 и не делятся на 7, 13, 17 и 19.2) Для любого введенного значения X определите значение y=5x/x-4


Информатика (12 баллов) | 141 просмотров
0

Я сам понятия не имею как это делать

0
0

Тогда надо уточнить у того кто давал задание )

0

Я примеры скинул, вот задания кто делал
Определить, делится ли целое число Х на 9 и не делятся на 7, 15, 17 и 19.
Для любого введенного значения X определите значение у=

0

На втором фото написанно, что у = (3*х-5)/(х-8)

0

Так что какая-то формула для у была )

0

Увидел! Там неправильно открылся файл y=5x/x-4

0

Поздравляю! )

0

Теперь дополни задачу, чтобы всем было видно )

0

Дополнил

Дан 1 ответ
0 голосов

Ответ:

1.

program z1;

var x: integer;

begin

write ('x = ');

readln (x);

if (x mod 5 = 0) and (x mod 7 <> 0)and (x mod 13 <> 0)and (x mod 17 <> 0)and (x mod 19 <> 0) then write ('Число ',x,' делится на 5 и не делится на 7, 13, 17 и 19')

else write ('Число ',x,' не соответствует условиям')

end.

2.

program z2;

var x,y: real;

begin

write ('x = ');

readln (x);

y:= 5*x/(x-4);

write ('y = ',y)

end.

Объяснение:

Смотри картинки


image
image
(2.2k баллов)