ОЧЕНЬ ПРОШУ РЕШИТЬ ХОТЯ БЫ ОДНУ ИЗ ЭТИХ ЗАДАЧ! 1.Составить программу, по которой **...

0 голосов
58 просмотров

ОЧЕНЬ ПРОШУ РЕШИТЬ ХОТЯ БЫ ОДНУ ИЗ ЭТИХ ЗАДАЧ! 1.Составить программу, по которой на экране будет напечатано: «Числа равны (numbers are equal)», если все три заданных числа равны, в противном случае будет напечатано максимальное число.2.Рассчитать надбавку к зарплате за стаж, если стаж от 2 до 5 лет, надбавка составляет S1, если стаж от 5 до 10 лет – S2 руб. Ввести с клавиатуры зарплату и стаж, вывести надбавку и сумму к выплате. (в ответе код c++ или pascal)


Информатика (524 баллов) | 58 просмотров
Дан 1 ответ
0 голосов

Ответ:

1.Var x, y, z, i:integer;

Begin

Readln(x);

Readln(y);

Readln(z);

If x=y then begin

If y=z then Writeln('numbers are equal' )

else begin if y>z then Writeln(y) else Writeln(z)

End; end

else begin if x>y then i:=x else i:=y;

If i>z then Writeln(i) else Writeln(z) end

2.const s1 = 10000;

const s2 = 15000;

var sum,zp,st: integer;

begin

write('Введите стаж: ');

readln(st);

write('Введите зарплату: ');

readln(zp);

if (st>=2) and (st<=5) then sum:=zp+s1</p>

else if (st>5) then sum:=zp+s2;

writeln('Зарплата: ',zp);

writeln('Стаж: ',st);

if (st>=2) and (st<=5) then writeln('Надбавка: ',s1)</p>

else if (st>5) then writeln('Надбавка: ',s2);

writeln('Сумма к выплате: ',sum);

end.

Объяснение:

Решил даже 2 :)

(230 баллов)