ПОМОГИТЕ СРОЧНО ПОЖАЛУЙСТА ПРОГРАММИРОВАНИЕ ** PYTHON! ДАЮ 40 БАЛЛОВ Дано натуральные...

0 голосов
145 просмотров

ПОМОГИТЕ СРОЧНО ПОЖАЛУЙСТА ПРОГРАММИРОВАНИЕ НА PYTHON! ДАЮ 40 БАЛЛОВ Дано натуральные числа m и n. Составить программу для нахождения всех их общих делителей


Информатика (30 баллов) | 145 просмотров
Дан 1 ответ
0 голосов

Ответ:

Var i,m,n,s,t:integer;

Begin

write('Введите число m: ');readln(m);

  write('Введите число n: ');readln(n);

  if m > n then

  t:= n else t := m;

  for i := 1 to t do

    begin

      if ((m mod i) = 0) and ((n mod i) = 0) then

      s:= s + i;

    end;

       writeln(s);

       readln;

end.

Объяснение:

Как то так

(26 баллов)
0

Спасибо, а эти иероглифы на паскале шоле?

0

Не это PYTHON

0

тьі каво абманиваеш

0

хорошо, извините за кибербулинг, спасибо больше

0

это не питон)