Написать программу, которая выводит ** экран случайные числа в диапазоне от 1 до 10000...

0 голосов
45 просмотров

Написать программу, которая выводит на экран случайные числа в диапазоне от 1 до 10000 до тех пор, пока не выпадут ПОДРЯД 2 трёхзначных числа. Указанные числа должны быть выведены последними. Числа нужно выводить на одной строке через пробелы. Вывести также количество всех полученных случайных чисел. На ПИТОН!ПОЖАЛУЙСТА, СРОЧНО НАДО. БЕЗ МАССИВОВ СРОЧНОООООООООООООООООООООООООООООООООООООООООООООООООО


Другие предметы (56 баллов) | 45 просмотров
0

ПОЖАЛУЙСТААААААААААААААААААААААААААААААААА

Дан 1 ответ
0 голосов

Ответ:

k = 0

d = 0

while d != 2:

   import random

   n = random.randint (1,10000)

   print (n, end = ' ')

   k = k + 1

   if  (n > 99 and n < 1000) and (d == 0 or d == 1):

       d = d + 1

   else: d = 0

print ()

print ('Количество случайных чисел',k)

(2.2k баллов)