Помогите срочно! Программирование ** Python дано натуральные числа m и n. Составить...

0 голосов
108 просмотров

Помогите срочно! Программирование на Python дано натуральные числа m и n. Составить программу для нахождения всех их общих делителей


Информатика (30 баллов) | 108 просмотров
Дан 1 ответ
0 голосов

Відповідь:

n = int(input("n = "))

m = int(input("m = "))

q = 0

p = []

while True:

   q += 1

   c = n%q

   d = m%q

   if c == 0 and d == 0:

       p.append(q)

   if q>m or q>n:

       break

print("Все общие делители - ", p)

Пояснення:

(170 баллов)