5.Программа получает ** вход натуральное число N (3 ≤ N ≤100, N - нечетное). Выведите **...

0 голосов
220 просмотров

5.Программа получает на вход натуральное число N (3 ≤ N ≤100, N - нечетное). Выведите на экран таблицу размером NxN, средний столбец и средняя строка которой заполнены единицами, все остальные элементы нули.Язык Питон помогите подалуйста​


Информатика (34 баллов) | 220 просмотров
Дан 1 ответ
0 голосов

Ответ:

n = int(input())

a = [['0'] * n for i in range(n)]

for i in range(n):

    for j in range (n):

         a[i][n//2] = '1'

         a[n//2][j] = '1'

for l in a:

    print(*l)  

Объяснение:

С помощью цикла for сначала закрашивается вертикаль, потом горизонталь

(45 баллов)
0
Работает код не до конца.
0
Выдаёт не то, что нужно