Напишите программу, которая удаляет из введенной строки любой введенный с клавиатуры...

0 голосов
113 просмотров

Напишите программу, которая удаляет из введенной строки любой введенный с клавиатуры символ. pascal.abc даю 50 баллов срочно!!!!!


Информатика (12 баллов) | 113 просмотров
Дан 1 ответ
0 голосов

Ответ:

Тут значительно легче без процедур решить. Вот, получайте!

program prim;

Var

s : string;

t : char;

k: integer;

begin

writeln ('Введите строку');

readln (s);

writeln ('Введите символ, который надо удалить');

readln (t);

while pos(t,s)<>0 do

begin

k:=pos(t,s);

Delete(s, k, 1);

end;

writeln ('Результат после удаления: ');

writeln(s);

end.

(18 баллов)