Нужна помощь, помогите составить программу по данной блок-схеме(правая сторона)

0 голосов
105 просмотров

Нужна помощь, помогите составить программу по данной блок-схеме(правая сторона)


image

Информатика (12 баллов) | 105 просмотров
0

Левая сторона да, правая нет? Или наоборот?

0

правая

0

Что правая?

0

ой да, правая сторона это да, левая сторона это нет

0

наоборот

0

Левая-да, Правая-нет

0

Ой, а я не заметил в задании Правая сторона, это надо только по 1 стороне программу писать?

0

Если надо переделаю )

Дан 1 ответ
0 голосов

Ответ:

program z1;

var x: real;

begin

readln(x);

x:=x/4;

if x>= 15 then

begin

x:=x+12;

if x>20 then

begin

x:=x*5;

x:=x-25

end

else

begin

x:=x*3;

x:=x+13

end

end

else

begin

x:=x+6;

if x>=10 then

begin

x:=x*11;

x:=x+24

end

else

begin

x:=x*4;

x:=x-8

end

end;

writeln (x)

end.

1. 20 (x = 4)

2. 220 (x = 148)

Объяснение:

Левая сторона - да, правая сторона - нет (относительно человека смотрящего на схему)

(2.2k баллов)
0

Спасибо огромное