Написать программу, которая, используя подходящую подпрограмму, возводит число х в...

0 голосов
81 просмотров

Написать программу, которая, используя подходящую подпрограмму, возводит число х в степень n. Как можно проще.


Информатика (12 баллов) | 81 просмотров
Дан 1 ответ
0 голосов

Відповідь:

Если язык указать сложно - вот питон:

def stepen(x,n):

   return x**n

x = 4

n = 5

print(stepen(x,n))

либо можно максимально коротко:

def stepen(x,n):

   return x**n

print(stepen(3,2))

если нужно,чтобы ты сам вводил x и n, то:

def stepen(x,n):

   return x**n

x = float(input("x = "))

n = float(input("n = "))

print(stepen(x,n))

Пояснення:

(170 баллов)