Напишите программу которая вычисляет сумму всех четных чисел в диапазоне от 1 до n.

0 голосов
185 просмотров



Напишите программу которая вычисляет сумму всех четных чисел в диапазоне от 1 до n.



Информатика (24 баллов) | 185 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
    i, n, sum: integer;

begin
    writeln('Введите n');
    readln(n);
    ///Тут возможны два решения, с циклом и без. Вот первое:
    sum := 0;
    for i := 1 to n do
        if i mod 2 = 0 then
            sum := sum + i;
    writeln(sum);
    
    ///Второе, более быстрое, использующее формулу суммы первых членов арифметической прогрессии:
    if n mod 2 = 1 then n := n - 1;
    writeln(((2 + n) div 2) * n div 2);
end.

(55.0k баллов)