Помогите, пожалуйста, с информатикой. Нужно написать программу в...

+378 голосов
3.8m просмотров

Помогите, пожалуйста, с информатикой. Нужно написать программу в паскале. Задание: Массивы. Ввести массив из 7 элементов. Сдвинуть элементы этого массива на 1 элемент вправо.


Информатика (19 баллов) | 3.8m просмотров
Дан 1 ответ
+115 голосов

Ответ:

const N = 10;

var a: array [1..N] of integer;

begin

 for var i:=1 to N do

   a[i] := Random(100);

 writeln('Элементы массива a: ');

 for var i:=1 to N do

   write(a[i],' ');

 writeln;  

 for var i:=N downto 2 do

   a[i] := a[i-1];

 a[1] := 0;

 

 writeln('После сдвига влево: ');

 for var i:=1 to N do

   write(a[i],' ');

 writeln;  

end.

Объяснение:

(211 баллов)