** вход программе подается число n. Программа формирует n случайных чисел и находит сумму...

0 голосов
69 просмотров

На вход программе подается число n. Программа формирует n случайных чисел и находит сумму тех из них, которые больше 5 но меньше 100.

написать программу на любом языке. Лучше паскаль


Информатика (12 баллов) | 69 просмотров
Дан 1 ответ
0 голосов

Program gt;
var a,s,i,N:longint;
begin
readln(N);
s:=0;
RANDOMIZE;
for i:=1 to N do
begin
a:=random(500)-250;
if(a>5)and(a<100)then s:=s+a;<br>end;
writeln(s);
end.

(6.6k баллов)