Помогите составить программу по информатике!!!
Ответ:
Program task;
var num, n, x: integer;
begin
Write('Введите число: ');
ReadLn(num);
n:= 0;
x:= 0;
while num <> 0 do Begin
n:= n * 10 + num mod 10;
if (num mod 10) = 7 then
n:= n * 10 + 7;
num:= num div 10;
end;
while n <> 0 do Begin
x:= x * 10 + n mod 10;
n:= n div 10;
WriteLn(x);
end.