написать программу,которая выводит ** экран суммарный путь спортсмена за N дней...

0 голосов
40 просмотров
написать программу,которая выводит на экран суммарный путь спортсмена за N дней тренировки.Если известно,что спортсмен,начав тренировку,в первый день пробежал 5 км,каждый день он увеличивает дневную норму на 17% нормы предыдущего дня.ПОМОГИТЕ ПОЖАЛУЙСТА!!Желательно решение в 3 способах

Информатика (116 баллов) | 40 просмотров
Дан 1 ответ
0 голосов

Program sportsman;
var N, S, i : real;
begin
writeln('Введите количество дней тренировки');
readln(N);
S:=5
for  i := 1 to N-1 do
S:= S+5/100*17;
writeln('За это количество дней тренировок спортсмен пробежал', S, 'км');
readln;
end.

(24 баллов)