Нужна помощь, срочно! Взяв за основу задачу program n_2, составить программу для...

+795 голосов
1.6m просмотров

Нужна помощь, срочно! Взяв за основу задачу program n_2, составить программу для вычисления формулы k=2m+n


Информатика (12 баллов) | 1.6m просмотров
Дан 1 ответ
+56 голосов

Ответ:var n:byte;

a,b,h:real;

begin

writeln ('Введи номер фигуры 1-квадрат, 2-трапеция, 3-круг, 4-прямоугольник');

readln(n);

if n=1 then

begin

writeln ('Введи сторону квадрата');

readln(a);

writeln('Площадь квадрата=',sqr(a));

end;

if n=2 then

begin

writeln ('Введи длины оснований и высоту');

readln(a, b, h);

writeln ('Площадь трапеции =', (a+b)/2*h:1:1);

end;

if n=3 then

begin

writeln ('Введи радиус');

readln(a);

writeln ('Площадь круга =', pi*sqr(a):1:1);

end;

if n=4 then

begin

writeln ('Введи длины cторон');

readln(a, b);

writeln ('Площадь прямоугольника =', a*b);

end;

end.

Объяснение:

(64 баллов)