Пожалуйста очень надо. Пришлите либо фото либо напишите программу здесь

+334 голосов
1.5m просмотров

Пожалуйста очень надо. Пришлите либо фото либо напишите программу здесь


image

Информатика (30 баллов) | 1.5m просмотров
+80

почему "наверное"?

+103

Паскаль наверное

+181

На каком языке?

Дано ответов: 2
+174 голосов

var a:integer;

begin

   write('Введите трёхзначное число: ');

   readln(a);

   if (a >= 100) and (a <= 999) then</p>

       writeln((a div 100) + (a mod 10))

   else writeln('Ошибка! Это не трёхзначное число.');

end.


image
(152k баллов)
+66 голосов

Ответ:

  • var s,n: integer;
  • begin
  • read(n);
  • s := n div 100 + n mod 10;
  • write(s);
  • end.

или более гибкий вариант, складывает первую и последнюю цифру числа независимо от того, трёхзначное число или нет:

  • var n: integer;
  • begin
  • read(n);
  • Print(n.ToString.First.ToDigit + n.ToString.Last.ToDigit);
  • end.

Пример работ:


image
image
(3.7k баллов)