Даю 50 баллов! Срочно! Составить блок-схему и написать программу ** языке Паскаль...

+371 голосов
3.0m просмотров

Даю 50 баллов! Срочно! Составить блок-схему и написать программу на языке Паскаль выводящую на экран таблицу значений функции f(x) для х є [a;b] (a,b - целые, a>b) с шагом -1​


image

Информатика (12 баллов) | 3.0m просмотров
Дано ответов: 2
+139 голосов

Ответ:

program z1;

var a,b,x: integer;

f:real;

begin

write ('a = ');

readln (a);

write ('b = ');

readln (b);

for x:=a to b do

begin  

if x>2 then f:=x*x-3

else if x

else f:=abs(x-2);

writeln ('f(',x:2,') = ',f)

end

end.

Объяснение:

Смотри картинку

Это цикл для a < b c шагом 1.

Если цикл для a > b c шагом -1, то 9 строку (for x:=a to b do) заменяем на for x:=a downto b do.


image
(2.2k баллов)
+174 голосов

f(x) = x2 -2

сам решал могут быть не большие погрешности

(26 баллов)
+86

чуть позже напишу

+71

можно решение?