Составьте программу к задаче: Возвести данное число в куб,если оно чётное, и увеличить **...

0 голосов
69 просмотров

Составьте программу к задаче: Возвести данное число в куб,если оно чётное, и увеличить на 3, если оно-нечётное

PS: Pascal


Информатика | 69 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
var
a: integer;
begin
writeln('Введите число: ');
read(a);
if a mod 2 <> 0 then writeln('Число нечетное: ',a+3)
else writeln('Число четное: ',a*a*a);
end.
(1.4k баллов)
0 голосов

Uses crt;
var i:integer;
begin
     readln(i);
     if i mod 2=0 then writeln(power(i,3))
        else writeln(i+3);
end.

(7.2k баллов)