5.Программа получает ** вход натуральное число N (1 ≤ N ≤100). Выведите ** экран таблицу...

+275 голосов
2.8m просмотров

5.Программа получает на вход натуральное число N (1 ≤ N ≤100). Выведите на экран таблицу размером NxN, заполненную по следующему правилу: по краям таблицы стоят 0, а в середине X. Язык Питон помогите срочно плиз​


Информатика (44 баллов) | 2.8m просмотров
Дан 1 ответ
+109 голосов

Ответ:

n = int(input())

a = [['0'] * n for i in range(n)]

for i in range(1, n-1):

    for j in range (1, n-1):

         a[i][j] = 'X'

for l in a:

    print(*l)

Объяснение:

Сначала программа получает число, и создает двумерный массив NxN, заполненный нулями. Затем идет цикл, который заполняет иксами все, кроме боковых сторон

(45 баллов)