Вывести ** экран первые 20 чисел Фибоначчи. Напишите программу ** языке Pascal и...

+475 голосов
1.8m просмотров

Вывести на экран первые 20 чисел Фибоначчи. Напишите программу на языке Pascal и постройке блок схему (цикл с предусловием) ​


Информатика (17 баллов) | 1.8m просмотров
Дан 1 ответ
+61 голосов

Ответ:

var

   a,b,c,i,n: integer;

begin

n:= 20;

   a := 0;

   write(a,' ');

   b := 1;

   write(b,' ');

   for i:=3 to n do begin

       write(a+b,' ');

       c := b;

       b := a + b;

       a := c

   end;  

readln ;

end.


image
(4.1k баллов)