Программирование ** Python. Звездный треугольникДано нечетное натуральное число nn....

+193 голосов
2.7m просмотров

Программирование на Python. Звездный треугольникДано нечетное натуральное число nn. Напишите программу, которая печатает равнобедренный звездный треугольник с основанием, равным nn в соответствии с примером:* ** *** **** *** ** *Формат входных данныхНа вход программе подается одно нечетное натуральное число.Формат выходных данныхПрограмма должна вывести треугольник в соответствии с условием.Примечание. Используйте вложенный цикл for!​


Информатика (93 баллов) | 2.7m просмотров
+116

хорошо

+168

Если не работает - убери "while 1:0" в конце

+133

А если треугольник не в ту сторону?

+69

Напомните, как округлить в большую сторону?

+185

понятно

Дано ответов: 2
+196 голосов

nn = int(input())

x = ''

for i in range(1, nn // 2 + 2):

   x = ''

   for z in  range(i): x += '*'

   print(x)

mas = [None] * (nn // 2)

m = 0

for i in range(0, nn // 2): mas[i] = '*' * (i + 1)

for i in range(0, len(mas)):

   m = len(mas) - i - 1

   print(mas[m])

можно было-бы сделать все в 3 строки, но чего-то нельзя в for сделать шаг в обратную сторону

(528 баллов)
+65

в обратную сторону? а не подойдет вот так: for I in range(3, 1, -1)

+189

точно

+182

И это странно

+89 голосов

Ответ:

======================

Объяснение:

(243 баллов)