Написать программу ** языке Pascal.

+853 голосов
2.5m просмотров

Написать программу на языке Pascal.


Информатика (75 баллов) | 2.5m просмотров
Дан 1 ответ
+111 голосов

Ответ:

В условии слишком мало данных для нахождения закономерности в "cosx + cos2x - cos3x+...+cos13x" , поэтому сочтём за опечатку и напишем программу для "cosx + cos2x + cos3x + ... + cos13x".

  • var x,S:real;
  • begin
  • Read(x);
  • for var i := 1 to 13 do
  • S := S + Cos(i*x);
  • Write(S);
  • end.

PascalABC.NET:

  • begin
  • var x := ReadReal;
  • (1..13).Sum(i->Cos(i*x)).Print
  • end.
(3.7k баллов)