Помогите с программированием С++ Разработать программу ** языке C++ для решения следующей...

+433 голосов
3.0m просмотров

Помогите с программированием С++ Разработать программу на языке C++ для решения следующей задачи. Заданы два числа — A и B , первое в системе счисления с основанием p , второе в системе счисления с основанием q . Вычислить значение по указанной формуле и вывести его на экран в десятичной системе счисления и системе счисления с основанием r. p=7 q=4 r=5 Нужно написать программу именно на С++


Другие предметы (40 баллов) | 3.0m просмотров
Дан 1 ответ
+124 голосов

#include

#include

#include

using namespace std;

int to_10(int num, int syst){

   int res = 0,cnt = 0;

   while(num > 0){

       res += num % 10 * pow(syst,cnt);

       cnt++;

       num /= 10;

   }

   return res;

}

int to_r(int num,int r){

   string s;

   while(num > 0){

       s += num % r + '0';

       num /= r;

   }

   reverse(s.begin(),s.end());

   return stoi(s);

}

signed main() {

   int a,b,p=7,q=4,r=5;

   cin >> a >> b;

   a = to_10(a,p);

   b = to_10(b,q);

   int ans = pow(a,2) + 2 * a + pow(b,2);

   cout << ans << "(10)\n";</p>

   ans = to_r(ans,r);

   cout << ans << "(" << r << ")\n";</p>

}

(152k баллов)
+150

Спасибо!!!