Написать программу ** с++ Голодная зима. Суточный рацион коровы составляет u кг сена, v...

+463 голосов
4.7m просмотров

Написать программу на с++ Голодная зима. Суточный рацион коровы составляет u кг сена, v кг силоса и wкг комбикорма. В хозяйстве, содержащем стадо из k голов, осталось s кг сена, t кг силоса и f кг комбикорма.. В стаде ежедневно погибает p% коров; ежедневно q% оставшегося сена сгнивает; r% силоса разворовывается колхозниками; t% комбикорма распродает зав. фермой. Когда нельзя будет кормить всех оставшихся коров по полному рациону? Какой из видов кормов кончится раньше других?


Информатика | 4.7m просмотров
Дан 1 ответ
+86 голосов
Правильный ответ

#include

#include

#include

#include

#include

using namespace std;

bool myfunction (int i,int j) { return (i

int main() {

setlocale(0, "");

srand(time(0));

float u(0.0f), v(0.0f), w(0.0f); //суточный рацион коровы, состоящий из сена, силоса и комбикорма

float k(0.0f); // колво голов в ъозяйстве

float s(0.0f), t(0.0f), f(0.0f); // сколько осталось сена, силоса и комбикорма

float percP(0.0f); //  в день погибает % коров

float percQ(0.0f), percR(0.0f), percT(0.0f); //  в день сгнивает сена, силоса и комбкорма %

int dayCounter = 0;

cout

cin >> u;

cout

cin >> v;

cout

cin >> w;

cout

cin >> k;

cout

cin >> s;

cout

cin >> t;

cout

cin >> f;

cout

cin >> percP;

cout

cin >> percQ;

cout

cin >> percR;

cout

cin >> percT;

while(1) {

if(s

cout

 break;

}

if(t

 cout

 break;

}

if(f

 cout

 break;

}

cout

cout << "Осталось коров: " << static_cast<int>(k)

// кормим коров

s-=u;

t-=v;

f-=w;

//конец дня. Заного считаем припасы и коров.

k=k/100*(100-percP);

s=s/100*(100-percQ);

t=t/100*(100-percR);

f=f/100*(100-percT);

++dayCounter;

}

system("pause");

}

(291 баллов)
+106

cout << "День: " << dayCounter << " ";<br /> cout << "Осталось коров: " << static_cast(k) << endl;<br /> // кормим коров
s-=u;
t-=v;
f-=w;
// конец дня. Заного считаем припасы и коров.
k=k/100*(100-percP);
s=s/100*(100-percQ);
t=t/100*(100-percR);
f=f/100*(100-percT);
++dayCounter;
}
system("pause");
}

+143

while(1) {
if(s cout << "Кончилось сено. Прожито дней: " << dayCounter << ". Осталось коров: " << k;<br /> break;
}
if(t cout << "Кончился силос. Прожито дней: " << dayCounter << ". Осталось коров: " << k;<br /> break;
}
if(f cout << "Кончился комбикорм. Прожито дней: " << dayCounter << ". Осталось коров: " << k;<br /> break;
}

+131

cout << "Сена в день: ";<br /> cin >> u;
cout << "Силоса в день: ";<br /> cin >> v;
cout << "Комбикорма в день: ";<br /> cin >> w;
cout << "Всего коров: ";<br /> cin >> k;
cout << "Осталось сена: ";<br /> cin >> s;
cout << "Осталось силоса: ";<br /> cin >> t;
cout << "Осталось комбикорма: ";<br /> cin >> f;
cout << "Сколько % в день погибает коров: ";<br /> cin >> percP;
cout << "Сколько % пропадает сена: ";<br /> cin >> percQ;
cout << "Сколько % пропадает силоса: ";<br /> cin >> percR;
cout << "Сколько % пропадает комбикорма: ";<br /> cin >> percT;

+177

setlocale(0, "");
srand(time(0));
float u(0.0f), v(0.0f), w(0.0f); // суточный рацион коровы, состоящий из сена, силоса и комбикорма
float k(0.0f); // колво голов в ъозяйстве
float s(0.0f), t(0.0f), f(0.0f); // сколько осталось сена, силоса и комбикорма
float percP(0.0f); // в день погибает % коров
float percQ(0.0f), percR(0.0f), percT(0.0f); // в день сгнивает сена, силоса и комбкорма %
int dayCounter = 0;

+88

#include
#include
#include
#include
#include
using namespace std;
bool myfunction (int i,int j) { return (iint main() {