Написать программу (мини-игру) ** Python "Правда/ложь". В чем задание - программа будет...

+674 голосов
2.5m просмотров

Написать программу (мини-игру) на Python "Правда/ложь". В чем задание - программа будет выводить какие-то "факты", а пользователь будет решать, правда это или ложь. У пользователя будут 3 жизни, которые при неправильном решении будут уменьшатся. Ваше задание - написать именно код этих жизней и показать на основе двух "фактов" (рандомных, например, сегодня мне Знания дают такой забавный факт - "У синего кита такие большие вены, что по ним сможет проплыть маленький ребенок" etc.), как их добавлять, ибо нужно больше чем 2. Деталь: 1) если пользователь напишет какую-то белиберду вместо Правда/неправда, программа сообщит об ошибке и попросит повторить. Очень попрошу за 30 балов реализовать такое, если возможно. Задание непривычное, но, это вам не формулы в Паскале. Тех, кто не знает, как писать код и что такое Python, прошу не спамить; и вообще - бегите, глупцы!


Информатика (2.0k баллов) | 2.5m просмотров
+128

Если возможно, то с текстовика или эти факты будут в самой программе (хотя тогда она будет долгой). Вам не нужно писать откуда-то эти факты. Я могу их добавить, просто покажите пример на где-то 2 фактах.

+185

И откуда эта правда-ложь должна факты грузить? С базы данных, текстовика, из интернета качать?

Дан 1 ответ
+108 голосов

Ответ:

--- Python 3.8.3 ---

import typing

from typing import List  

from typing import AnyStr

from typing import Tuple

from typing import Callable

from typing import Any

class FactPackLoader:

   def __init__(self, TrueCode: str = '1', FalseCode: str = '0', encoding: AnyStr = 'utf-8',):

       self._encoding = encoding

       self._trueAnswCode = TrueCode

       self._falseAnswCode = FalseCode

   def LoadPack(self, FactPackPath: AnyStr, AnswSplitter: AnyStr = ':: ') -> Tuple[AnyStr, int]:

       with open(FactPackPath, 'r', encoding=self._encoding) as data:

           RawData = data.read().split('\n')

       for FactPair in RawData:

           FactPair = tuple(FactPair.split(AnswSplitter))

           yield (FactPair[0], self._ToBool(FactPair[1]))

           

   def _ToBool(self, replyCode):

       if replyCode == self._trueAnswCode: return True

       return False  

def main():

   f = FactPackLoader()

   print('"Правда-Ложь"\nАвтор: KnowsUser1\nVersion: 0.0.1 Ya-Sdelyal')

   IsGameRunning = 'y'

   while IsGameRunning == 'y':

       lives = 3

       fp = input('Укажите имя файла, содержащего пак фактов:\n')

       facts = f.LoadPack(fp)

       for i, Q in enumerate(facts):

           print(f'Вопрос {i+1}:\n{Q[0]}')

           reply = True if input().lower() == 'да' else False

           if reply != Q[1]:

               lives -= 1

               print(f'Вы не поверите, но тот факт, что {Q[0]}, действительно является правдой!\nЖизней осталось: {lives}')

           else:

               print(f'Вы совершенно правы!')

           if lives

               print('Вы проиграли')

               IsGameRunning = input('Попробуем ещё раз? Y/N\n').lower()

               break

       else:

           print('Поздравляем, вы успешно выполнили все задания из файла!')

           IsGameRunning = input('Сыграем ещё раз? Y/N\n').lower()

if __name__ == "__main__":

   main()

В файле с паком вопросов после каждого вопроса должен быть указан код ответа (по умолчанию - 1 - истина, 0 - ложь), отделённый от вопроса особым символом/набором символов (по умолчанию - ':: ')

Коды ответа при необходимости в изменении указываются при создании экземпляра FactPackLoader(), символ-разделитель - при вызове LoadPack().

По умолчанию в файле с заданиями пара вопрос ответ выглядит так:

//facts.txt

На самом деле солнце белого цвета :: 1

После "::" должен стоять пробел

P.S - Код main() можно и нужно рефакторить, ибо сейчас это нечто страшное.

P.S 2 Да, я часто обращаю внимание на плохой код людей, а сейчас сам его написал. Вынепонимаете, этодругое =))

P.S 3 Проверял, программа работает. Если что то сломалось, виноват сайт. На всякий случай прикреплю файл исходного кода в .txt

(1.6k баллов)
+53

Емм во первый это не мне писали что бы я помогла если кто-то не знал

+170

1 - я не пишу на Js. 2 - вам в комментариях уже задали вопросы, на которые вы не смогли ответить. А значит, что если я что то и сделаю, то потом начнётся вынос моего мозга с "А нас не так учили", "А надо было не так".

+71

Добрый день помогите пожалуйста с вопросом по информатике он уже задан вот ссылка https://znanija.com/task/37777203 даю 50 баллов

+147

"Как сделать такой выбор" - да поможет вам оператор if. Конкретно в нашей ситуации - можно добавить ещё одну функцию, на которую возложить обязанность решать, откуда и как грузить вопросы. Потому что ещё логику в main пихать - это уже реально преступление против хорошего кода будет)

+130

Не подскажите, пожалуйста, как сделать такой выбор, ибо в программировании полный ноль?