** вход программе подается два натуральных числа a и b (a < b). Напишите программу,...

+204 голосов
601k просмотров

На вход программе подается два натуральных числа a и b (a < b). Напишите программу, которая находит все простые числа от a до b включительно. Python


Информатика | 601k просмотров
Дан 1 ответ
+78 голосов

var a, b, i, j, l: integer;

begin

read(a, b);

for i:=a to b do

begin

j:=2;

l:=round(sqrt(i));

while (i mod j <> 0) and (j <= l) do</p>

inc(j);

if j > l then write(i, ' ');

end;

end.

(65 баллов)