Напишите программу (Паскаль):выводится 5 строк, в которых сначала записан порядковый...

0 голосов
44 просмотров

Напишите программу (Паскаль):
выводится 5 строк, в которых сначала записан порядковый номер строки с точкой, а затем слово. вывести слова в алфавитном порядке.
например :
1.информатика
2.химия
3.математика
4.физкультура
5.литература
Вывод: 1.информатика
5.литература
3.математика
4.физкультура
2.химия


Информатика (26 баллов) | 44 просмотров
Дан 1 ответ
0 голосов

Uses crt;
const n=5;
var    
s:array[1..n] of string; 
  i,j,c:integer; 
  ss:string;
begin
writeln('Введите :');
for i:=1 to n do begin 
 write('s[',i,']='); 
 readln(s[i]);                       
 end;
for i:=1 to n-1 do
for j:=i+1 to n do
if s[i]>s[j] then 
begin 
 ss:=s[i]; 
 s[i]:=s[j]; 
 s[j]:=ss; 
end;
 for i:=1 to n do
writeln(i,'.',s[i],'  ');
end.

(20.8k баллов)