Toggle navigation
Все ответы
Имя пользователя или адрес электронной почты
Пароль
Запомнить
Вход
Регистрация
|
Я забыл свой пароль
Вопросы
Горячее!
Без ответов
Категории
Задать вопрос
Помогите плииз напишите программу
+517
голосов
469k
просмотров
Помогите плииз напишите программу
помогите
плииз
напишите
программу
информатика
студенческий
Информатика
Aleksandraliva_zn
(
222
баллов)
18 Дек, 24
|
469k
просмотров
ответить
комментировать
Ваш комментарий к вопросу:
Отображаемое имя (по желанию):
Напишите мне, если после меня будет добавлен комментарий:
Напишите мне, если после меня добавят комментарий
Конфиденциальность: Ваш электронный адрес будет использоваться только для отправки уведомлений.
Анти-спам проверка:
Чтобы избежать проверки в будущем, пожалуйста
войдите
или
зарегистрируйтесь
.
Прокомментировать
Отмена
Ваш ответ
Отображаемое имя (по желанию):
Отправить мне письмо на это адрес если мой ответ выбран или прокомментирован:
Отправить мне письмо если мой ответ выбран или прокомментирован
Конфиденциальность: Ваш электронный адрес будет использоваться только для отправки уведомлений.
Анти-спам проверка:
Чтобы избежать проверки в будущем, пожалуйста
войдите
или
зарегистрируйтесь
.
Ответить
Отмена
Дан
1
ответ
+44
голосов
C++20
Код:
#include
#include
double frand(double min, double max)
{
auto f = ((double) rand() / (RAND_MAX));
return min + f * (max - min);
}
template
void print_arr(T cont, int n, Func printer) {
for (auto x = 0; x < n; ++x) {
printer(x, cont[x]);
}
}
int main() {
constexpr short n = 17;
constexpr double min = 37.0;
constexpr double max = 38.0;
constexpr int eps = 1;
std::srand(std::time(nullptr));
double t[n];
for (double & x : t) {
x = frand(min, max);
}
auto printer = [](int x, double t){std::cout << 12 + x << " сентября: t = " << std::fixed << std::setprecision(eps) << t << std::endl;};</li>
print_arr(t, n, printer);
return 0;
}
MaxLevs_zn
(
7.0k
баллов)
18 Дек, 24
задать связанный вопрос
комментировать
Ваш комментарий к ответу:
Отображаемое имя (по желанию):
Напишите мне, если после меня будет добавлен комментарий:
Напишите мне, если после меня добавят комментарий
Конфиденциальность: Ваш электронный адрес будет использоваться только для отправки уведомлений.
Анти-спам проверка:
Чтобы избежать проверки в будущем, пожалуйста
войдите
или
зарегистрируйтесь
.
Прокомментировать
Отмена
Похожие задачи
Выберете операции, которые относятся к форматированию? Объединение двух абзацев в...
Помогите решить задачу по информатике
Требовалось написать программу, при выполнении которой с клавиатуры считывается...
Определить истинность (ложность) высказываний: a) «7*8=48 или Земля – планета» b)...
Помогите пожааалуйста!!!!!