Даны натуральные числа А и В (В<А). написать программу , выводящую ** экран сумму...

0 голосов
75 просмотров

Даны натуральные числа А и В (В<А). написать программу , выводящую на экран сумму натуральных чисел от В до А, включая В и А. <br>


Информатика | 75 просмотров
Дано ответов: 2
0 голосов

Uses crt;const  h=10;var  a,b,S: integer;
begin  write('A= '); readln(a);  write('B= '); readln(b);  S:=0;  while b<>a+1 do  begin    S:=S+b;    inc(b);  end;  writeln('Сумма - ',S);end.

(630 баллов)
0 голосов

Var a,b,sum:integer;
begin
readln(a,b);
for b:=b+1 to a do
sum:=sum+b;
writeln(sum);
end.

(558 баллов)