Напишите программу которая получает два целых числа и находит их произведение не...

0 голосов
86 просмотров

Напишите программу которая получает два целых числа и находит их произведение не используя операцию умножения. учтите что числа могут быть отрицательными.На Turbo Pascal пожалуйста срочно!!!!!Зарвнее спасибо!


Информатика (24 баллов) | 86 просмотров
Дан 1 ответ
0 голосов

Вот. Умножение без помощи операции умножения. Делай лучшим) program pr; var i,a,b:integer;p:real; begin write('Первый множитель: '); readln(a); write('Второй множитель: '); readln(b); if b<0 then begin b:=-b; for i:=1 to b do begin p:=p+a; end; writeln(-p:0:2); end else begin for i:=1 to b do p:=p+a; writeln(p:0:2) end; end.

(1.0k баллов)