Напишите программу, которая по введенному целому числу А (0≤ А ≤ 999999) находит сумму...

0 голосов
55 просмотров

Напишите программу, которая по введенному целому числу А (0≤ А ≤ 999999) находит сумму цифр этого числа S.


Информатика (14 баллов) | 55 просмотров
Дан 1 ответ
0 голосов

Var a,col:integer;
s:string;
begin
readln(a);
if (a<0) OR (a>999999) then
writeln('Число А не соответствует условию')
else
begin
s:=IntToStr(a);//Переводим из числовой в строковую величину
col:=length(s);
writeln('Количество: ',col);
end;
end.

(43 баллов)