Нужно написать программу в Паскале срочно: С клавиатуры вводится число n. Заполнить...

0 голосов
19 просмотров

Нужно написать программу в Паскале срочно: С клавиатуры вводится число n. Заполнить массив с клавиатуры n значениями и вывести их произведение.


Информатика (20 баллов) | 19 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
var
  a: array of byte; //Мы ведь не хотим выйти за пределы даже Int64?
  n, i: byte;          //Больше и не пригодится, массива из 255 значений хватит уж
  l: Int64 := 1;      //Произведение - большая цЫферка

begin
  readln(n);
  System.Array.Resize(a, n);
  for i := 0 to (n - 1) do
  begin
    write('a[', i, '] = ');
    readln(a[i]);
    l *= a[i];
  end;
  writeln(l);
end.
(16.9k баллов)