Помогите !!написать программу которая для 3х значного числа если оно четное то возводит в...

0 голосов
28 просмотров

Помогите !!написать программу которая для 3х значного числа если оно четное то возводит в квадрат ,а если не четное то находит сумму цифр


Информатика (14 баллов) | 28 просмотров
0

в pascalabc?

0

Дар

0

Да

0

Var   A:integer;BeginWriteLn('Введи число.');ReadLn(A);if (A mod 2=0) then A:=sqr(A)else A:=((A mod 100)div 10)+(A mod 10)+(A div 100);WriteLn(A);ReadLnEnd.

0

Ну или так:Var A:integer;BeginWriteLn('Введи число.');ReadLn(A);if (A mod 2=0) then begn A:=sqr(A); WriteLn('Квадрат введённого числа равен: ',A); endelse begin A:=((A mod 100)div 10)+(A mod 10)+(A div 100); WriteLn('Сумма цифр введённого числа равна: ',A); end;ReadLnEnd.

0

Var A:integer;BeginWriteLn('Введи число.');ReadLn(A);if (A mod 2=0) then begin A:=sqr(A); WriteLn('Квадрат введённого числа равен: ',A); endelse begin A:=((A mod 100)div 10)+(A mod 10)+(A div 100); WriteLn('Сумма цифр введённого числа равна: ',A); end;ReadLnEnd.

0

var a:integer;

0

упс.я нечаянно)

Дан 1 ответ
0 голосов

Var
A: integer;

begin
readLn(A);
if (A mod 2 = 0) then
begin
A := sqr(A);
WriteLn('Квадрат введённого числа равен: ', A);
end else
begin
A := ((A mod 100) div 10) + (A mod 10) + (A div 100);
writeLn('Сумма цифр введённого числа равна: ', A);
end;
end.