Дана строка. Указать те слова, которые содержат хотя бы одну букву k. Составить программу...

0 голосов
104 просмотров

Дана строка. Указать те слова, которые содержат хотя бы одну букву k. Составить программу на Паскаль. Заранее спасибо ^_^


Информатика (21 баллов) | 104 просмотров
Дан 1 ответ
0 голосов

Var s,tmp:string;
     i,n:integer;
     flag,word:boolean;
function letter (const let:char):boolean;
 begin
   if ((let>='a') and (let<='z')) or ((let>='A') and (let<='Z')) then letter:=true<br>     else letter:=false;
 end;
begin
  readln (s);
  s:=s+' ';
  n:=length(s);
  flag:=false;
  for i:=1 to n do
   begin
     if (letter(s[i])) and (not flag) then
      begin 
        flag:=true;
        tmp:='';
        word:=false;
      end else if (not letter(s[i])) and (flag) then
      begin 
       flag:=false;
       if (word) and (not (tmp='')) then writeln (tmp);
      end;
     if (flag) then
      begin 
        tmp:=tmp+s[i];
        if (s[i]='k') then word:=true;
      end; 
   end;
end.

(2.8k баллов)