Составить программу и блок схему вывода всех чисел от 1000 до 9999, в которых 1 цифра...

0 голосов
55 просмотров

Составить программу и блок схему вывода всех чисел от 1000 до 9999, в которых 1 цифра равна 4 и 2 цифра равна 3.


Информатика (77 баллов) | 55 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Почему-то мой ответ удалили. Напишу подробнее.
Если в чмсле первая цифра 4 и вторая цифра 3, то  числа от 4300 до 4399
На паскле программа выглядит так
var i, n: integer
begin
uses crt;
for i:= 0 to 99
begin
n = 4300 + i;
write (n);
end;
writeln;
end.
Блок-схема совсем простая, нарисуй сама.
1) Начало (в овале)
2) i = 0 (в прямоугольнике)
3) n = 4300 + i (в прямоугольнике)
4) Вывод n (в параллелограмме)
5) Проверка i > 99 ? (в ромбе). Если нет, возврат на п. 3. Если да, вниз.
6) Вывод пустой строки (в параллелограмме)
7) Конец (в овале)

(320k баллов)