Как программируется цикл с предусловием ** паскале?почему алгоритм вычисления N! должен...

0 голосов
325 просмотров

Как программируется цикл с предусловием на паскале?
почему алгоритм вычисления N! должен быть циклическим ?
что такое математическая формализация задачи?


Информатика (26 баллов) | 325 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

1. while <условие> do
        begin
              <действие>
              <действие>
             .......
        end;
2. Не обязательно, например, можно это сделать рекурсивно:
     1. \ var \ n:integer; \\ 
2. \ function \ fact(j:integer):integer; \\ 
3. \ \ \ \ begin \\ 
4. \ \ \ \ \ \ \ if \ (j=1) \ or \ (j=0) \ then \ fact:=1 \\ 
5. \ \ \ \ \ \ \ else \ fact:=j*fact(j-1); \\ 
6. \ \ \ \ end; \\ 
7. \ begin \\ 
8. \ \ cls; \\ 
9. \ \ write('Vvedite \ n='); \\ 
10. \ \ readln(n); \\ 
11. \ \ writeln('n!=',fact(n)); \\ 
12. \ end.
3. создание математической модели данной задачи, (гyгл в помощь).

(5.2k баллов)