Помогите написать программу в паскале и подробно описать Присвойте z значение большего из...

0 голосов
22 просмотров

Помогите написать программу в паскале и подробно описать
Присвойте z значение большего из x и y в том случае если x<0 и меньшего если x>=0


Информатика (28 баллов) | 22 просмотров
Дан 1 ответ
0 голосов

Var x,y,z:integer; {описание переменных и их типа}
begin
writeln ('введи два числа'); {Вывод на экран сообщения-подсказки}
readln (x,y); {считывание переменных}
if x<0 then                      {проверка условия.}<br>  if y>x then z:=y             {если условие истинно, то мы ищем большее из х и у. если                                        у больше, то присваиваем z значение у}
           else z:=x             {если же больше х, то присваиваем его значение}
        else                        {если условие ложно}
           if y>x then z:=x     {то мы ищем меньшее из х и у. если                                                                           у больше, то присваиваем z значение х}
                    else z:=y;     {если же больше х, то присваиваем значение у}
writeln (z);                        {вывод результата на экран}
end.                                 {конец программы}

(844 баллов)