Напишите программу ** языке паскаль, которая генерирует 10 случайных чисел в диапазоне от...

0 голосов
113 просмотров

Напишите программу на языке паскаль, которая генерирует 10 случайных чисел в диапазоне от 1 до 20, выводит эти числа на экран и вычисляет их среднее арифметическое.


Информатика (146 баллов) | 113 просмотров
Дан 1 ответ
0 голосов

Var a,i,b:integer;
s:real;
begin
a:=0;
for i:=1 to 10 do begin
b:=random(20)+1;
a+=b;
write(b,' ');
end;
writeln;
s:=a/10;
writeln(s);
end.

(4.7k баллов)