Составить программу в ПаскалеСоставить программу, чтобы компьютер запросил имя...

0 голосов
259 просмотров
Составить программу в Паскале
Составить программу, чтобы компьютер запросил имя пользователя и
его год рождения, затем подсчитал
количество лет, дней и минут, прожитых, примерно, этим человеком. Результаты вывести
на экран.

Информатика (514 баллов) | 259 просмотров
0

какой язык?

0

Паскаль

Дан 1 ответ
0 голосов
Правильный ответ

Type ye=1850..2100;
var year, year1:ye;
    name:string;
    a:integer;

begin
writeln('Какой сейчас год?');
readln(year);
writeln('Твое имя?');
readln(name);
writeln('В каком году ты родился(родилась)?');
readln(year1);
a:=year-year1;
writeln('Твое имя ', name);
writeln('Ты прожил ', a, ' Лет(года)');
writeln('Ты прожил приблизительно ', a*365, ' дней');
writeln('Ты прожил приблизительно ', a*364*24, ' часов');
end.



(1.3k баллов)