. Составить программу, решающую следующую задачу: возраст Коли – X лет, а возраст Миши –...

0 голосов
135 просмотров
. Составить программу, решающую следующую задачу:
возраст Коли – X
лет, а возраст Миши – Y
лет. Найти их средний возраст, а также определить, на сколько возраст одного
мальчика отличается от возраста другого.

Информатика (14 баллов) | 135 просмотров
Дан 1 ответ
0 голосов

#include

using namespace std;
int main(){
int a,s,d,f;

setlocale(0,"");

cout<<endl<<"Введите возраст Коли:";</span>
cin>>a;

cout<<endl<<"Введите возраст Миши:";</span>
cin>>s;

if (a>s && a>0 && s>0) {

d=a-s;
f=(a+s)/2;
cout<<endl<<"Коля старше Миши на: "<<d<<" лет"<<endl;</span>
cout<<"Средний возраст ребят: "<<f<<" лет"<<endl;</span>
}

if (a0 && s>0) {
d=s-a;
f=(a+s)/2;
cout<<endl<<"Миша старше Коли на: "<<d<<" лет"<<endl;</span>
cout<<endl<<"Средний возраст ребят: "<<f<<" лет"<<endl;</span>
}

if (a<0 || s<0) {</span>
cout<<endl<<"Вы ввели отрицательное число"<<endl;</span>
}

system ("pause");

return 0;
}

(14 баллов)