УКАЖИТЕ МОЮ ОШИБКУ. или напишите программу,мне чем проще,тем лучше. Нужно написать...

0 голосов
32 просмотров

УКАЖИТЕ МОЮ ОШИБКУ. или напишите программу,мне чем проще,тем лучше.

Нужно написать программу,которая выбирает максимальное значение из 5 введеных чисел.

Program Xai;uses crt;var a,b,c,d,e,max:real;Begin clrscr;writeln('Введите 5 чисел');readln(a,b,c,d,e);if a>b then max:=a else max:=b;if c>max then max:=c;if d>c then max:=d;if e>d then e:=max;writeln('Максимальное значение является---> ',max);readlnend.

Информатика (150 баллов) | 32 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

For i:=1 to 5 do
read(x);
if maxend;
writeln(max);

(212 баллов)
0

i x max peremenki

0

если честно,то эти команды впервые вижу:с

0

это через цикл

0

чтобы не вводить 5 переменных и не много условий было

0

мне бы просто с ветвлениями